API - Company Filings History outage
Incident Report for DueDil
Resolved
This incident has been resolved.
Posted May 11, 2022 - 08:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2022 - 20:22 UTC
Identified
Company Filings are currently impacted by a 3rd party provider.
We are closely monitoring the situation, please accept our apologies for the inconvenience.
Posted May 10, 2022 - 16:19 UTC
This incident affected: DueDil API (Ownership).