Director details in list csv exports are not showing
Incident Report for DueDil
Resolved
A temporary fix will be made available shortly. Please contact us if you require CSV exports.
Posted Oct 20, 2020 - 09:17 UTC
Identified
We have identified a fix for this issue and is likely to be deployed in the coming weeks.
Posted Oct 19, 2020 - 09:36 UTC
Investigating
We are currently investigating the issue
Posted Oct 05, 2020 - 11:32 UTC
This incident affected: DueDil Web Platform (Web Application - app.duedil.com).