Web app is currently unavailable and returning a 404 error
Incident Report for DueDil
Resolved
The web app is now available.

The issue related to infrastructure issues with our cloud service provider. We have planned for an upgrade of these services on February 1st 18:00 GMT however we have encountered an issue in the interim period.

We apologise for the inconvenience this has caused.
Posted Jan 22, 2021 - 11:25 UTC
Identified
We have identified an issue and currently looking for a solution.
Posted Jan 22, 2021 - 08:45 UTC
Investigating
We are currently investigating the issue impact the web app.
Posted Jan 22, 2021 - 08:05 UTC
This incident affected: DueDil Web Platform (Web Application - app.duedil.com).